Gauges going dead when gas petal is pressed

Discussion in 'Freightliner Forum' started by blazer_72, Jan 7, 2021.

  1. blazer_72

    blazer_72 Bobtail Member

    20
    4
    Nov 18, 2015
    Louisiana
    0
    I have a 2003 freightliner coronado when driving down the road it is doing some crazy things, when you press the gas petal all the gauges stop working when let it go they all start back up, it acts just like what happens when you first turn the key on. It even does this on cruise, when you start to climb and the cruise kicks in they all go off or just stay where they last were, when the cruise kicks out they come back on, even the ac quits when this happens. Any ideas.
     
  2. Truckers Report Jobs

    Trucking Jobs in 30 seconds

    Every month 400 people find a job with the help of TruckersReport.

  3. QUALITYTRUCK

    QUALITYTRUCK Road Train Member

    1,508
    1,338
    Jun 14, 2009
    romulus,mi
    0
    Type "qualcomm" in search box and read some of my previous, lengthy posts.
     
    baha Thanks this.
  4. jeephustler

    jeephustler Bobtail Member

    1
    1
    Jan 18, 2021
    0
    Different circumstances, but may be related to your issues.

    I have a 2005 Freightliner M2 Box Truck with Mercedes Engine that was giving me some problems this week. The engine would start and run, but had either a too low or much too high idle speed. Also the temp and oil pressure gauges, tach and throttle pedal would not work making the truck undriveable. It seemed to me that the engine and truck were not communicating. I checked every fuse, relay and module connection I could find. I checked the engine computer, the bulkhead module, all the firewall connnectors, everything I could think of. I was told by a tech to look at the C3 connector on the frame mounted Chassis module under the cab I did not know was down there. The connectors were all clean and tight. While it was running in the limp state, I had a hunch to tap on the chassis module with my flashlight. First tap, the truck hiccupped and everything smoothed out. So there is a loose connection or some flaw inside the chassis module causing all my frustrations.

    Just wanted to share in case it helps someone else out.
     
    QUALITYTRUCK Thanks this.
  • Truckers Report Jobs

    Trucking Jobs in 30 seconds

    Every month 400 people find a job with the help of TruckersReport.

  • Draft saved Draft deleted