Help... no oil pressure on Cummins ISX 15

Discussion in 'Heavy Duty Diesel Truck Mechanics Forum' started by GatorKenworth001, Dec 5, 2019.

  1. GatorKenworth001

    GatorKenworth001 Bobtail Member

    23
    7
    Jun 9, 2013
    0
    Is it possible for oil pump to just wear out? Oil pressure had been gradually decreasing that last 7 weeks. Pressure came way up significantly after oil and filter change, but dropped back down after 4-5 days. Yesterday while in shop to get starter replaced, had oil filter changed again. We have 0.0 oil pressure now. Gauges and sensors check out good. Need expert advice.
    Thanks
     
  2. Roberts450

    Roberts450 Road Train Member

    1,728
    2,361
    Feb 6, 2016
    0
    Check it with a mechanical gauge to confirm the electric gauge is working? And yes oil pumps can wear out but sounds more like you’re having issues with the pressure relief valve thats in the oil pump.
     
    AModelCat Thanks this.
  3. GatorKenworth001

    GatorKenworth001 Bobtail Member

    23
    7
    Jun 9, 2013
    0
    They put a manual gauge on it, still no oil pressure.
     
  4. GatorKenworth001

    GatorKenworth001 Bobtail Member

    23
    7
    Jun 9, 2013
    0
    We checked the relief spring and plunger on top of filter housing. It seemed fine. But is there a pressure regulator in the pump also??
     
  5. GatorKenworth001

    GatorKenworth001 Bobtail Member

    23
    7
    Jun 9, 2013
    0
    Did you see my replies?
     
  6. Roberts450

    Roberts450 Road Train Member

    1,728
    2,361
    Feb 6, 2016
    0
    Im not 100% sure but the ones on the filter housing is probably for by-passing a plugged filter and yes there should be a pressure relief built into the pump.
     
    pushbroom Thanks this.
  7. Roberts450

    Roberts450 Road Train Member

    1,728
    2,361
    Feb 6, 2016
    0
  8. GatorKenworth001

    GatorKenworth001 Bobtail Member

    23
    7
    Jun 9, 2013
    0
    Ok. Might be valve in pump then.
     
  9. pushbroom

    pushbroom Road Train Member

    1,330
    5,489
    Sep 1, 2012
    0
    Yes there is a regulator in the pump. I think I would be looking for other damage or at least pulling a main or rod cap while you are down there.
     
  10. GatorKenworth001

    GatorKenworth001 Bobtail Member

    23
    7
    Jun 9, 2013
    0
    Lower end is all brand new about 139,000 miles ago.
     
  • Draft saved Draft deleted