I need some help - Antenna Warning on SWR Check

Discussion in 'CB Radio Forum' started by HD_Renegade, Jun 15, 2011.

  1. trogbad

    trogbad Bobtail Member

    1
    0
    Nov 8, 2011
    NY
    0
    Hey HD Renegade Had same problem same radio same model. Even bought new antennas i see it was a waste of money there i joined here just to get the help i aparently cant send messages until i have 7 posts and this wont let me post my email address maybe it will allow u to send me a pm? could you please try and if it works send the PDF please Thanks!
     
  2. Truckers Report Jobs

    Trucking Jobs in 30 seconds

    Every month 400 people find a job with the help of TruckersReport.

  3. mike5511

    mike5511 Road Train Member

    2,989
    1,346
    May 15, 2011
    NW Arkansas
    0
    You did what I'm bad to do, jump in on an old thread. Now say something back and get another post to your credit!:biggrin_25525: Oh yeah, and welcome.
     
    shroomhauler Thanks this.
  4. HD_Renegade

    HD_Renegade Road Train Member

    1,470
    601
    Dec 20, 2010
    North Carolina
    0
    I sent you a PM on this.
     
  5. mewiredup

    mewiredup Bobtail Member

    1
    0
    Nov 22, 2011
    Dinwiddie, VA
    0
    Hi HD,
    I installed my cobra 29 today and am having same problems. I would greatly appreciate a copy of that pdf from cobra. Im new to forums and stuff to. So what will you need from me to email or send copy to me?

    Thank You
     
  6. HD_Renegade

    HD_Renegade Road Train Member

    1,470
    601
    Dec 20, 2010
    North Carolina
    0
    No problem, send me a PM with your e-mail addy and I will send you the PDF file I got from Cobra. Very simple fix.
     
  7. CondoCruiser

    CondoCruiser The Legend

    19,726
    18,705
    Apr 18, 2010
    Tennessee
    0
    I agree with your disagree. :) Any short can cause that. I racked my brains one time and it turned out it was the brand new braided cable I just put in. It had a dead short.

    I was reading on a CB forum yesterday. Even having ungrounded metal parts will create distortion. Like your doors, etc. It recommends using grounding straps to bridge the gap instead of running grounds straight to your antenna mounts. Even if the door is not used, still ground it.

    The OP probably had a poor fender ground with all the painted parts. A ground strap probably would of improved his situation.
     
  8. Fuzzcheek1

    Fuzzcheek1 Bobtail Member

    1
    0
    Nov 29, 2011
    0
    I really hate to make this post any longer, but I'm having the same issue with my SWR on the same radio. 7 posts to be able to PM... I apologize to the moderators in advance.
     
  9. HD_Renegade

    HD_Renegade Road Train Member

    1,470
    601
    Dec 20, 2010
    North Carolina
    0
    The Admins of the site asked me to upload the PDF File to fix the antenna issue, and the told me how to do this so here goes.

    I have gotten like 8 requests for this file, so I hope this will help other people too.
     

    Attached Files:

  10. mike5511

    mike5511 Road Train Member

    2,989
    1,346
    May 15, 2011
    NW Arkansas
    0

    Cool, thanks
     
  11. kevinmoffo

    kevinmoffo Bobtail Member

    1
    0
    Mar 6, 2012
    mingo jucntion ohio
    0
    i have a cobra in my home i hooked it up to a dipole indoor base antenna 18ft for b radio- workmen bs1, i cant get the swr under 2.5 on channel 40 and not under 3.0 on channel 1 and the warning antenna wont go off. any way i can fix this
     
  • Truckers Report Jobs

    Trucking Jobs in 30 seconds

    Every month 400 people find a job with the help of TruckersReport.

  • Draft saved Draft deleted