Ishift - Whine sound

Discussion in 'Volvo Forum' started by palmeris, May 8, 2024.

  1. palmeris

    palmeris Bobtail Member

    7
    4
    May 18, 2023
    0
    2019 860- purchased used with 592000 ish miles. has a turbo like whine sound from tranny in any gear up to 6th, once past 6th it disappears - no codes thrown - shifts fine with no apparent issues- anyone seen this before, thoughts?
     
  2. Truckers Report Jobs

    Trucking Jobs in 30 seconds

    Every month 400 people find a job with the help of TruckersReport.

  3. 86scotty

    86scotty Road Train Member

    4,072
    10,619
    Aug 27, 2017
    Appalachia
    0
    Last fluid/filter change? Fluid level?
     
    Siinman and palmeris Thank this.
  4. palmeris

    palmeris Bobtail Member

    7
    4
    May 18, 2023
    0
    Fluids and filter changed last month, less thank 2k miles since. Cold level on site glass is right at Minimum . sight glass.jpg
     
    86scotty Thanks this.
  5. KB3MMX

    KB3MMX Road Train Member

    3,068
    2,587
    Dec 29, 2014
    Orrstown, PA
    0
    I'm guessing 13 or 14 speed?

    If so , that's 100% normal on the "X series" (HD) iShift with hardened gear set
     
    palmeris and 86scotty Thank this.
  6. palmeris

    palmeris Bobtail Member

    7
    4
    May 18, 2023
    0
    Thank you for the reply.
    It is a standard I-shift 12 speed. It has the performance shifter push button selectors on the dash. It also makes the turbo whine sound if your in manual .
    Its a D13 425 HP 1750 with a 2.64
     
    Old mark and KB3MMX Thank this.
  7. 86scotty

    86scotty Road Train Member

    4,072
    10,619
    Aug 27, 2017
    Appalachia
    0
    I can't help but I'm curious what you find out. For reference my fluid sits about there too and I had it done about 6 months ago.
     
    KB3MMX and palmeris Thank this.
  8. nasriza

    nasriza Road Train Member

    2,373
    2,047
    Feb 1, 2013
    Chicago, IL
    0
    the only thing that will change in the trans before and after 6 gear is your range selection in the back might have a bad bearing for output shaft that is whining also might be a slight angle adjustment on your driveline but i do not believe so. most likely something with range synchro or a bearing starting to fail. that fluid level is little bit low for my liking need to probably add a little bit maybe about .5 to 1 gal.
     
    KB3MMX and palmeris Thank this.
  9. palmeris

    palmeris Bobtail Member

    7
    4
    May 18, 2023
    0
    Thank you very much for the response. It did seem to be right at the min mark , I figured the service shop had a purpose for it being that low...sigh. So do I put fluid in at location 3 or 4 on this diagram? tranny page.jpg
     
  10. palmeris

    palmeris Bobtail Member

    7
    4
    May 18, 2023
    0
    It also has the brass drain plug so I use the 75w-80 correct? tranny fluid.jpg
     
  11. nasriza

    nasriza Road Train Member

    2,373
    2,047
    Feb 1, 2013
    Chicago, IL
    0
  • Truckers Report Jobs

    Trucking Jobs in 30 seconds

    Every month 400 people find a job with the help of TruckersReport.