ISX Engine Power Issue, won't go over 40mph

Discussion in 'Heavy Duty Diesel Truck Mechanics Forum' started by rgvloads, Jan 21, 2021.

  1. rgvloads

    rgvloads Bobtail Member

    1
    0
    Jan 21, 2021
    0
    I am having power issues with my Peterbilt truck with ISX engine. My original engine went bad and I put in another used engine. Here are the issues with new (used) engine:
    *Truck does not go faster than 40mph loaded. No power
    *I had turbo rebuilt to no avail
    * Changed turbo hoses since they were leaking a little oil
    Do you guys think it may be the used engine I put in?

    Thoughts?
     
  2. Truckers Report Jobs

    Trucking Jobs in 30 seconds

    Every month 400 people find a job with the help of TruckersReport.

  3. Harpreet1396

    Harpreet1396 Bobtail Member

    7
    2
    Jun 26, 2019
    Fontana,CA
    0
    Could you post a list of active and inactive codes? Pretty hard to diag low power with no info....
     
  4. baha

    baha Road Train Member

    3,581
    2,130
    Jul 25, 2013
    ga
    0
    Did you get the ecm. off the truck that you got the motor out of, if not you may need to get your ecm. reset to match your new eng.?
     
  5. AModelCat

    AModelCat Road Train Member

    19,987
    89,085
    Jul 7, 2015
    Canuckistan
    0
    Well it could be a dozen different things. Chances are its a programming issue.

    Was it the same year and CPL number? Came out of a similar model truck?
     
  • Truckers Report Jobs

    Trucking Jobs in 30 seconds

    Every month 400 people find a job with the help of TruckersReport.

  • Draft saved Draft deleted