Paccar

Discussion in 'Peterbilt Forum' started by Bret1984, Jun 17, 2022.

  1. Bret1984

    Bret1984 Medium Load Member

    319
    573
    Mar 4, 2020
    Fort Worth, TX
    0
    Drop nosed style truck.
     
    Dave_in_AZ Thanks this.
  2. Truckers Report Jobs

    Trucking Jobs in 30 seconds

    Every month 400 people find a job with the help of TruckersReport.

  3. Accidental Trucker

    Accidental Trucker Road Train Member

    2,816
    5,795
    Jun 4, 2015
    0
    I should have my second in November. Very little issues on the first, a couple of wiring breaks and just replaced the DEF level sensor. One other sensor, can’t remember which one.

    There was trouble with cams the first year or two (a decade ago), but the last six years have been pretty reliable. I talk to the shop manager at the local KW dealership occasionally about what problems he sees, and they just don’t see much.
     
    Bret1984, Long FLD and JoeyJunk Thank this.
  4. JoeyJunk

    JoeyJunk Road Train Member

    4,496
    25,142
    Dec 31, 2010
    Washington, PA
    0
    Same thing my buddy was told. Very reliable.
     
    Bret1984 and Accidental Trucker Thank this.
  5. Long FLD

    Long FLD Road Train Member

    6,854
    24,804
    Mar 4, 2015
    0
    On my last truck I had wiring issues where they bundled them up below the firewall where they went back under the cab. Had all kinds of weird lighting problems, like I’d be sitting at home and someone would tell me headlights and 4 ways were flashing while it’s parked over at the shop. Ended up with 7 or 8 broken wires in the bundle. Fast forward to last week, I get a bulletin in the mail for my new truck. Wires bundled too tight on the bracket below the firewall. Lol.

    But as far as my last truck, sold it right at 600k. I had to do 2 NOx sensors, the def level sensor, cleaned the dpf once at 250k and then replaced it at 500k, I did do the starter and alternator but can’t remember when.
     
  6. Lysdexis

    Lysdexis Road Train Member

    4,407
    47,273
    Oct 25, 2018
    Arkansas
    0
    I have a 500/1850 13spd with 640k on it in a 15 T800 that's deleted. Only major issue I've had was a valve mashed the seat into a knife edge. Pulled the head and put a new valve in that hole and I've been running it ever since. I get around 6mpg and walk off on my buddy with an isx15 at 525.

    Screenshot_20220708-191226_Messenger.jpg

    When I had the head off I snapped a pic of the cyl walls.

    20220412_160510.jpg
     
    Bret1984 Thanks this.
  • Truckers Report Jobs

    Trucking Jobs in 30 seconds

    Every month 400 people find a job with the help of TruckersReport.

  • Draft saved Draft deleted