Phantom rev limiter?

Discussion in 'Trucks [ Eighteen Wheelers ]' started by HillbillyDeluxeTruck, Jul 1, 2020.

  1. HillbillyDeluxeTruck

    HillbillyDeluxeTruck Road Train Member

    4,481
    22,097
    Mar 3, 2013
    San Antone
    0
    2012 Peterbilt 386 with an ISX.

    Randomly my truck in 10th gear will not rev above 1570rpm. The pedal goes dead, boost drops off and the truck will not accelerate any more. Normally it will spin to 1640rpm in top gear. While I don't drive fast enough to hit that limiter, there are times when Im passing someone and need the extra rpm to pass them quickly. This problem can last for days/weeks/months then go away.

    Im going to inspect the speed sensor on the transmission to start, but can a camshaft position/speed sensor cause this? I am getting a random stored code for the CPS, but the truck always starts and runs perfect. Not even a hiccup.
     
  2. Truckers Report Jobs

    Trucking Jobs in 30 seconds

    Every month 400 people find a job with the help of TruckersReport.

  3. Cattleman84

    Cattleman84 Road Train Member

    4,339
    18,647
    Nov 1, 2017
    The Sticks, Idaho
    0
    Soumds like you might need an exrosist... Lol
     
    Rideandrepair Thanks this.
  4. BoxCarKidd

    BoxCarKidd Road Train Member

    2,845
    3,608
    Aug 26, 2014
    0
    An older Pet I worked on had two transmission speed sensors. Others had one sensor with four wires that work the same way.
    Back to the older everything else worked fine. When that sensor acted up RPM on the N14 was limited to 1500 RPM.
    If you can be code free solves many problems. Sorry I don't know much about the CPS on your truck.
     
  • Truckers Report Jobs

    Trucking Jobs in 30 seconds

    Every month 400 people find a job with the help of TruckersReport.

  • Draft saved Draft deleted