replaced ecm and now code 433

Discussion in 'Trucks [ Eighteen Wheelers ]' started by earthmover, Nov 19, 2009.

  1. earthmover

    earthmover Medium Load Member

    563
    20
    Jan 27, 2009
    castalia , north carolina
    0
    had the ecm replaced on my dump with m11 now has code 433 and fan run all the time..whats the deal. :biggrin_25513:
     
  2. Truckers Report Jobs

    Trucking Jobs in 30 seconds

    Every month 400 people find a job with the help of TruckersReport.

  3. FYDA FREIGHTLINER CINCY

    FYDA FREIGHTLINER CINCY Light Load Member

    270
    130
    Apr 28, 2009
    Cincinnati, ohio
    0
    that code is for intake manifold pressure circuit. check to make sure all your pins at ecm connector are ok.
     
  4. earthmover

    earthmover Medium Load Member

    563
    20
    Jan 27, 2009
    castalia , north carolina
    0
    ok i'll check what about the fan running all the time
     
  5. FYDA FREIGHTLINER CINCY

    FYDA FREIGHTLINER CINCY Light Load Member

    270
    130
    Apr 28, 2009
    Cincinnati, ohio
    0
    that sensor is also the intake manifold temp sensor. the engine sees to high of intake temp it will turn the fan on
     
  6. vegetto

    vegetto Bobtail Member

    20
    5
    Dec 14, 2006
    0
    On an M-11, the intake pressure sensor and intake temp sensor are two different sensors with separate codes. So this code will not effect the fan operation.

    I would unplug your boost sensor (this is the 3-pin sensor on the intake manifold) and see if 122 code comes active. This will prove the signal circuit is ok. Measure voltage at the connector on the two outter pins. You should get around 5 volts. If so, power and ground is good and we can replace the sensor.
     
  7. earthmover

    earthmover Medium Load Member

    563
    20
    Jan 27, 2009
    castalia , north carolina
    0
    where on the intake would it be located??? and what would make the fan stay on ........was told it maybe a bad ecm but cummins atlantic wants me to pay $97.00hr to find out and it's there ecm:biggrin_2551:
     
  8. FYDA FREIGHTLINER CINCY

    FYDA FREIGHTLINER CINCY Light Load Member

    270
    130
    Apr 28, 2009
    Cincinnati, ohio
    0
    intake pressure will be front sensor on the intake.. and u sure the ecm parameter for your fan is right
     
  9. FYDA FREIGHTLINER CINCY

    FYDA FREIGHTLINER CINCY Light Load Member

    270
    130
    Apr 28, 2009
    Cincinnati, ohio
    0
     
  10. earthmover

    earthmover Medium Load Member

    563
    20
    Jan 27, 2009
    castalia , north carolina
    0
    took it back to cummins atlantic was told be the tech that something was wrong could be ecm....i paid 3553.19 to have ecm and new mounts put on and set ecm back and they said it was a starter a alt. or a ecm problem and for 97.00hr and 2 hrs from the time they took it that morn. it could be fixed...i had already paid for the ecm to be program and want me to pay again.....set my speed oh. also the speed o will work for a few min. then it goes to 40mph then 20 then back to speed that im running.. i forgot about that......i think ecm but im not a tech.....i really need to fix this and get back to work this was last week:biggrin_2551:
     
  11. FYDA FREIGHTLINER CINCY

    FYDA FREIGHTLINER CINCY Light Load Member

    270
    130
    Apr 28, 2009
    Cincinnati, ohio
    0
    what was the orginal complaint when u took it into the shop? if it neds up being an ecm . then it would be under warrenty.
     
  • Truckers Report Jobs

    Trucking Jobs in 30 seconds

    Every month 400 people find a job with the help of TruckersReport.

  • Draft saved Draft deleted