Spn 2659 fmi 18 HELP!! Im on the road

Discussion in 'Volvo Forum' started by Movingismylifeilovemoving, Sep 5, 2016.

  1. Movingismylifeilovemoving

    Movingismylifeilovemoving Light Load Member

    140
    183
    Aug 5, 2015
    0
    Thanks for the info. With what Volvo wanted to charge I told them to put it back together.

    It's been running fine but I odviously want to fix it. I got 600k on the clock and wondering if I'm just gonna need an inflame in a shirt time anyway.

    How many miles on your truck?
     
  2. Vadimg12

    Vadimg12 Bobtail Member

    6
    2
    Jul 6, 2017
    0
    I have same mileage. If u driving in VAMDPA u I can do test for u for free and tell u if u need to do with it anything. My email vadimg12@gmail.com

    On my r
     
  3. Gio207

    Gio207 Bobtail Member

    4
    3
    Jan 5, 2019
    0
    Did you have any issues driving it to Houston for those 1500 miles? The code just came up on my truck
     
    AlexD13 Thanks this.
  4. Movingismylifeilovemoving

    Movingismylifeilovemoving Light Load Member

    140
    183
    Aug 5, 2015
    0
    I was in Houston. I took it to sweeten truck center. Very good Volvo dealer btw.

    They flashed the ecm and I was good to go.

    About 6 months later I needed to get an egr valve and clean the cooler. That was at Volvo in Reno. I'm pretty sure they screwed me

    If it derates you just unplug the speed sensor and drive to the shpp
     
    Gio207 Thanks this.
  5. Gio207

    Gio207 Bobtail Member

    4
    3
    Jan 5, 2019
    0
    Thank you for the quick reply! I just got prompted that the truck will go into derate in 60 minutes and also shown a message to do a parked regen, even though the soot level is low. If the regen doesn't do anything, I will try with the speed sensor and go from there. Thanks again!
     
    AlexD13 Thanks this.
  6. Movingismylifeilovemoving

    Movingismylifeilovemoving Light Load Member

    140
    183
    Aug 5, 2015
    0
    Good luck. This type of stuff is the worst part of trucking.

    Btw. If it's an I shift I dont think you can unplug the speed sensor. Also the tech and Jake's
    Wont work
     
  7. Gio207

    Gio207 Bobtail Member

    4
    3
    Jan 5, 2019
    0
    Just to update on my issue with the code, changing the EGR differential pressure sensor and updating the Venturi Tube fixed the issue (the sensor was clogged up and readings were different than normal). Truck has ran fine for about 1500 miles, now. So just a heads up, it's a good idea to check that sensor. Hope it helps others with this issue.

    Also, @Movingismylifeilovemoving , thank you for suggesting to remove the speed sensor. It saved me from being derated and having to get towed! It worked on the i-shift; however, the stick has the manual and + / - option on it. This might have something to do with it working on i-shifts that have that option.
     
    AlexD13 Thanks this.
  8. Movingismylifeilovemoving

    Movingismylifeilovemoving Light Load Member

    140
    183
    Aug 5, 2015
    0
    Glad to hear. Also good to know it works with I-shift. It's great when people come back and update
    There are so many threads with just problems and no solutions.

    I'm guilty of it too.

    I replaced my venturi pipe and sensor trying to chase down mpg problems previous to this problem but am also aware that that thing has caused problems.

    Crazy how much bigger the holes are for the sensor. Thay thing ain't gonna clog
     
  • Truckers Report Jobs

    Trucking Jobs in 30 seconds

    Every month 400 people find a job with the help of TruckersReport.

  • Draft saved Draft deleted