truck making clicking sounds and won't start

Discussion in 'International Forum' started by bulldog01, Jun 19, 2011.

  1. bulldog01

    bulldog01 Bobtail Member

    Jun 19, 2011
    baton rouge, LA
    after I shut my truck off and tried to start it up again it wouldn't start it was making clicking sounds. I thought it was the battery so I charged the battery up, put it back on the truck and turned the ignition on the nothing to same clicking noise. The clicking is coming from over by the ceilinoyed switch. I changed that out and still the same thing I think it maybe the starter i'm not sure
    sneh_inc Thanks this.
  2. Emulsified

    Emulsified Road Train Member

    May 6, 2010
    Dallas, TX
    could be a flat spot on the starter. could be a bad solonoid (but not likely). could be bad connections to the starter/solonoid from the batteries.
    I can't think of anything else.

    SHO-TYME Road Train Member

    Apr 20, 2011
    Dahlonega, GA
    Sounds funny but wack the starter with a hammer and see what happens.
    LindaPV and Mr c3rtifi3d Thank this.

    AUSSIE DAVE Road Train Member

    Feb 21, 2010
    OZ - Brisbane
    Bad connection. Or starter relay. Is click sound from engine bay or cab
  5. marek4792

    marek4792 Light Load Member

    Mar 21, 2011
    Chicago, IL
    check the ground cable (bout an inch in diameter) to the starter, had same symptoms in a volvo daycab.
  6. TheLittleGuy

    TheLittleGuy Medium Load Member

    Apr 13, 2008
    Nashville, TN
    the starter solenoid is piggybacked on the starter. The starter relay is on the firewall.
  7. Sparkz

    Sparkz Light Load Member

    Jul 10, 2011
    New Zealand
    Starter testing on engine. I assume the starter is a 12volt Delco 40MT, 42MT, or 50MT.
    Battery positive on large stud on top of the solenoid.
    Battery negative on the large stud on the rear of the starter. Also earth wire from here to a small stud on the solenoid.
    Starter energising wire on another small stud on the solenoid. This wire goes to a starter slave relay, usually nearby on the chassis or firewall etc. This relay has a positive cable on its other stud. The start button operates this relay which closes its contacts and powers up the energising wire to the main starter solenoid. The starter will then crank the engine.

    To test the system connect a voltmeter to the main positive and negative studs on the starter. Voltmeter should read at least 12volts.
    Press the start button and see if the voltage drops. If the starter doesn't work, but the voltage drops substantially you have problems in the main battery cables, isolation switch, or batteries.
    If the voltage doesn't drop by much, move the positive voltmeter lead to the solenoid energising wire.
    Press the start button again.
    If the voltmeter reads about 12volts with the start button pressed, the starter is faulty.
    If the voltmeter doesn't show any voltage it means that the relay is not working. This could be a faulty relay or wiring to it from the start button.

    Check for dirty connections on the copper link from the solenoid output stud to the starter fields. I have also seen this link break on Cummins engines.
  8. cjreckart

    cjreckart Bobtail Member

    Dec 3, 2009
    Uniontown Pa
    I have a 5900i and everytime i go to start it i have to turn the key multiple time due to the clicking . have replaced the starter and the batteries and still does it. i guess next is the key switch
  9. dave26027

    dave26027 Road Train Member

    Sep 10, 2009
    Dallas, Texas
    Could be anything between the alternator and starter. You've replaced the starter and batts, the grounds could be corroded, the positive or negative wires on the batts can be corroded, the wires to the starter or the ground cables could be corroded, the ground from the motor or trans to the batts could be corroded. Or the motor could be locked up. Have you been losing coolant?

    You're not trying to start it in gear, are you? (It's common).
  10. Heavyd

    Heavyd Road Train Member

    Feb 4, 2009
    You need to change the firewall solenoid.
  • Draft saved Draft deleted