Truck won't start

Discussion in 'Heavy Duty Diesel Truck Mechanics Forum' started by H-Town Trucking, Apr 2, 2021.

  1. H-Town Trucking

    H-Town Trucking Bobtail Member

    12
    4
    Sep 25, 2020
    0
    I have a 2007 KW W900 was driving @69-70 mph on Hwy it shut off but it came back on immediately did it like 3 times until it shut off and it didn't come back on changed my fuel filters nothing got it town back to the yard tow truck driver suggested for me to check my engine fuse the 30amp was burnt changed and it did it again so I started to look for any exposed wire found the pto wire that is connected to the positive on the battery was rubing on battery box fix it replaced the fuse and truck won't start but fixed the issue with the fuse doesn't pop any more can anyone help on what else to look for the truck crancks but won't start tried a little bit of starter fluid and nothing any suggestions thanks
     
  2. Truckers Report Jobs

    Trucking Jobs in 30 seconds

    Every month 400 people find a job with the help of TruckersReport.

  3. stillwurkin

    stillwurkin Road Train Member

    1,757
    2,849
    Dec 2, 2017
    0
    Sounds like no electrical current to injectors. If starting fluid won't get results. Check current feed to ecm may be a main fuse in battery box or close by. My c-15 wasn't shutting down but it was doing odd surges under acceleration. It was in the wires on left side of engine under plastic covers. Couple of them wore through. See if the fuel shut off is getting current. The one that lets fuel flow or shuts engine off with your ignition key. When it quit, did your dash lose current? Like in everything go dead? Had a wire once, that came apart down by starter. But it killed everything had to coast to the side. But that doesn't sound like the problem in your case.
     
  4. H-Town Trucking

    H-Town Trucking Bobtail Member

    12
    4
    Sep 25, 2020
    0
    Dash works just found my crankshaft sensor wires were burnt threw maybe it's that but can't get it out thanks for the info if that's doesn't work I'll keep checking wires
     

    Attached Files:

    stillwurkin Thanks this.
  5. kwcam

    kwcam Light Load Member

    155
    93
    Dec 29, 2012
    at the shop
    0
    Does the CEL and dash lights come on at key on ? if not it could be the ignition relay, just swap it with the accessory relay. have seen a few of these where driver shut the truck off and wouldn't start again.
    The broken crank sensor wire would cause a longer crank time before starting as it will run off the cam sensor.
     
  6. H-Town Trucking

    H-Town Trucking Bobtail Member

    12
    4
    Sep 25, 2020
    0
    Thanks I would check that finally took the crankshaft sensor off will get that replaced tomorrow thanks again
     
  7. H-Town Trucking

    H-Town Trucking Bobtail Member

    12
    4
    Sep 25, 2020
    0
    No luck changed the crankshaft sensor nothing swap the ign relay nothing it cranks but won't turn over what else can I check?? Thanks
     
  8. John E.

    John E. Light Load Member

    220
    842
    Apr 4, 2021
    New Brunswick
    0
    Possibly, could be a wire coming off your ignition switch, even the switch itself can give you a problem like this.
     
  • Truckers Report Jobs

    Trucking Jobs in 30 seconds

    Every month 400 people find a job with the help of TruckersReport.

  • Draft saved Draft deleted