Water temp troubles

Discussion in 'Peterbilt Forum' started by Mervin159, Oct 11, 2022.

  1. Mervin159

    Mervin159 Bobtail Member

    2
    2
    Oct 11, 2022
    0
    04 379 with Cat C15. Water temp high warning comes on but gauge only gets up to 150. I do think it is actually hot so gauge has to be wrong, right? What is most likely the problem?
     
  2. Truckers Report Jobs

    Trucking Jobs in 30 seconds

    Every month 400 people find a job with the help of TruckersReport.

  3. bad-luck

    bad-luck Road Train Member

    2,602
    4,480
    Nov 16, 2013
    Baltimore, Maryland
    0
    Get yourself a thermo heat gun. Check the tem that way. Sounds like your guage is not working.
     
  4. lester

    lester Road Train Member

    2,417
    6,096
    Jan 2, 2012
    NW, Iowa
    0
    There's to sensors, one for gauge and one for ecm. I assume warning light comes on when ecm sees high temp. Gauge in peterbilt is pretty well known to be inaccurate. I run a scangauge so I see the temp ecm sees. Never had much luck with dash gauge working well.

    Is fan kicking on? Is radiator dirty?
    Fan kicks on for water temp at 217.
     
    MartinFromBC Thanks this.
  5. MartinFromBC

    MartinFromBC Road Train Member

    2,769
    12,430
    Oct 19, 2018
    0
    Hose collapsing internally, thermostat stuck, low on coolant, fan failing, rad plugged?
     
  6. Mervin159

    Mervin159 Bobtail Member

    2
    2
    Oct 11, 2022
    0
    Blew radiator out yesterday and running at normal temp now, which I figured was the issue. Should’ve phrased my question better. Was asking more about fixing the gauge than what was causing truck to get hot. Thanks for the replies
     
    baha and MartinFromBC Thank this.
  • Truckers Report Jobs

    Trucking Jobs in 30 seconds

    Every month 400 people find a job with the help of TruckersReport.

  • Draft saved Draft deleted