14l no power

Discussion in 'Freightliner Forum' started by 06freightshacker, Mar 29, 2023.

  1. 06freightshacker

    06freightshacker Bobtail Member

    2
    0
    Mar 29, 2023
    0
    Hello all have a 06 columbia with a 14l it says 515 hp but dosent feel like it and when it spools up there is an other whistle like the turbo but sounds like the drivers side any help would be greatful
     
  2. Truckers Report Jobs

    Trucking Jobs in 30 seconds

    Every month 400 people find a job with the help of TruckersReport.

  3. little cat 500

    little cat 500 Road Train Member

    1,885
    951
    Jan 17, 2010
    Abbottstown PA
    0
    Sounds like a boost leak get out and look once.
     
  4. DDguy

    DDguy Light Load Member

    131
    83
    Apr 21, 2020
    Ont. Canada
    0
    I second the Motion Likly boot with a hole or loose clamp or something
     
  5. 06freightshacker

    06freightshacker Bobtail Member

    2
    0
    Mar 29, 2023
    0
    I've changed all the belows intake tube new boost actuator search all over
     
  6. DDguy

    DDguy Light Load Member

    131
    83
    Apr 21, 2020
    Ont. Canada
    0
    Have you Checked the Intake Manifold Gasket and also the EGR crossover pipe and the V/Band Clamp where the Intak manifold and the short pipe meet where egr crossover pipe comes together
     
  7. blairandgretchen

    blairandgretchen Road Train Member

    11,592
    57,521
    Dec 9, 2011
    South west Missouri
    0
    CAC pressure test to isolate at standing.

    Often those fresh clamps will need re-torqued after running a few miles, mine - last changed, needed nipping down twice, it had a real high pitch fart sound under boost.
     
    Oxbow Thanks this.
  • Truckers Report Jobs

    Trucking Jobs in 30 seconds

    Every month 400 people find a job with the help of TruckersReport.

  • Draft saved Draft deleted