Kenworth electrical

Discussion in 'Kenworth Forum' started by Ken worth7086, Oct 15, 2022.

  1. Ken worth7086

    Ken worth7086 Bobtail Member

    2
    0
    Oct 15, 2022
    0
    I have a 2006 kw t800 I have no power to the windshield wipers, cb, radio, and blower for the air conditioner it is a day cab. I have checked the fuses and we just replaced the batteries and nothing please help me
     
  2. Truckers Report Jobs

    Trucking Jobs in 30 seconds

    Every month 400 people find a job with the help of TruckersReport.

  3. AModelCat

    AModelCat Road Train Member

    25,644
    131,736
    Jul 7, 2015
    Canuckistan
    0
    If its got the fuse panel behind the clutch pedal, chances are its corroded up bad on the back side.
     
  4. Star Rider

    Star Rider Medium Load Member

    349
    2,476
    Sep 23, 2019
    Michigan
    0
    Also check key switch accessory power off the back of the ignition switch.
     
    singlescrewshaker Thanks this.
  5. blairandgretchen

    blairandgretchen Road Train Member

    10,944
    52,850
    Dec 9, 2011
    South west Missouri
    0
    I’m thinking accessory power relay, but I don’t know it’s location on that truck.
     
  6. Ken worth7086

    Ken worth7086 Bobtail Member

    2
    0
    Oct 15, 2022
    0
    Okay so now I have a new problem I have no power to the truck ### accessory or engine
     
  • Truckers Report Jobs

    Trucking Jobs in 30 seconds

    Every month 400 people find a job with the help of TruckersReport.

  • Draft saved Draft deleted