Thermoking SB-210 Communication failure lost controller connect

Discussion in 'Refrigerated Trucking Forum' started by FCBexpress, Jun 10, 2021.

  1. FCBexpress

    FCBexpress Bobtail Member

    1
    0
    Jun 10, 2021
    0
    Hi all,
    I have a Thermo king SB-210 with about 15k hours on it. I was recently driving with my reefer on and when I parked I came outside to an off unit with a message of "Communication failure lost controller connect". I initially was thinking maybe there's a wire that came loose with the rough drive, so I restarted the unit and it was running for about 2 hours with no movement and I got the same message again. Any ideas?

    Thanks in advance!
     
  2. Truckers Report Jobs

    Trucking Jobs in 30 seconds

    Every month 400 people find a job with the help of TruckersReport.

  3. reeferwrencher

    reeferwrencher Medium Load Member

    532
    1,449
    Aug 4, 2018
    0
    Tighten battery terminals then open control box.Check for 12 volts at board if it has 12 volts and led light in center of board isn't flashing then board is bad.
     
  4. BRTLLC

    BRTLLC Bobtail Member

    5
    3
    May 20, 2022
    0
    Hey I’m having the same issue with my trailer. I checked battery terminals 12 volts at the board and green light flashing. But will run for awhile then it does it again. And shows no codes. Can anyone help?
     
  5. reeferwrencher

    reeferwrencher Medium Load Member

    532
    1,449
    Aug 4, 2018
    0
    The board has a device on it called a poly switch.Sometimes it will start to fail when it gets hot.Typically unit will run and then eventually cut out.When you restart it will run again for a while then fail again.This could be your problem unfortunately the only fix for this is to replace the board.
     
  6. Wistech#100215

    Wistech#100215 Bobtail Member

    4
    1
    May 31, 2022
    0
    I had one do this last week with 10,000 some engine hrs, I open the relay box door found the inside VERY wet because the black Capplug had fallen out of its hole allowing water to get in from rain or outside trailer washing, I unhooked the battery right away then dried this box out completely, made sure the plug was back in place, I then test ran this unit set at 33⁰ for 24 hrs so far lucky not to need a new main board
     
    reeferwrencher Thanks this.
  • Truckers Report Jobs

    Trucking Jobs in 30 seconds

    Every month 400 people find a job with the help of TruckersReport.

  • Draft saved Draft deleted